Media Composer | First Forum

This forum is for Media Composer | First released on June 29th 2017. This is the place to seek advice, help, mentoring from experienced editors. This forum is especially helpful if you are new to editing or just want to become part of the Avid community.
Write a New Post
Page 10 of 25 (482 items) « First ... < Previous 8 9 10 11 12 Next > ... Last »
Topics Replies Views
Popular Post
MCF won't Install by TimPelton
» Latest post by Marianna , Mon, Jun 25 2018 3:51 PM
5 982
Popular Post
Frame Flex issue by Luigi
» Latest post by TechOne88 , Sat, Jun 23 2018 12:33 PM
4 1,453
Popular Post
Two Mono tracks export to stereo question by letsrock
» Latest post by letsrock , Thu, Jun 21 2018 9:01 PM
5 812
Popular Post
Auto Mounting Thumb Drive by Bolts55
» Latest post by RalphC , Tue, Jun 19 2018 4:53 PM
3 1,068
Popular Post
Avid Media/Project Workflow Question by Rory T
» Latest post by Rory T , Tue, Jun 19 2018 9:45 AM
1 581
Popular Post
Project settings for 4K, 2.35:1 F55 footage in Avid MC 8 by nickwnorton
» Latest post by Job ter Burg , Tue, Jun 19 2018 5:28 AM
3 1,564
Popular Post
"MC first" deinstalls "MC symphony" when trying... by soimn_htarl
» Latest post by camoscato , Mon, Jun 18 2018 1:56 PM
1 369
Popular Post
Import mpeg 4 codec by kfly
» Latest post by DStone , Fri, Jun 15 2018 12:14 AM
1 836
Popular Post
Application Manager stuck by tolentinora
» Latest post by Marianna , Wed, Jun 13 2018 12:43 PM
4 776
Popular Post
Three passes to "publish" to local drive? by RickP
» Latest post by Marianna , Mon, Jun 11 2018 3:29 PM
10 2,240
Popular Post
Trying to download Avid First by chuckkahn
» Latest post by chuckkahn , Wed, Jun 6 2018 8:32 PM
2 549
Popular Post
Importing or linking clips with 100fps by peterpeterson
» Latest post by peterpeterson , Wed, Jun 6 2018 3:07 PM
0 398
Popular Post
Application Manager won't connect, so I can't use MC First by Exalmus
» Latest post by RalphC , Tue, Jun 5 2018 4:03 PM
7 1,815
Popular Post
P2 Cards by 1979
» Latest post by Marianna , Thu, May 31 2018 4:39 PM
1 596
Popular Post
None of your installed products can be licensed via application manager by Bassnote
» Latest post by Forever1337 , Tue, May 29 2018 10:45 PM
1, 2, 3
34 10,010
Popular Post
Avid Media Composer First - Error in rendering by Jesper Hansen
» Latest post by Jesper Hansen , Tue, May 29 2018 9:19 PM
6 2,279
Popular Post
Weird zoom in Composer window by dib481
» Latest post by Marianna , Tue, May 29 2018 2:09 PM
12 3,652
Popular Post
Anamorphic to 2.39 in Avid? by chfarmer89
» Latest post by chfarmer89 , Mon, May 28 2018 3:51 PM
0 541
Popular Post
Frame Flex issue after update by Patrick Schonewille
» Latest post by Patrick Schonewille , Mon, May 28 2018 1:24 AM
0 398
Popular Post
New/first install of MC First today; won't launch. by jwhitwell
» Latest post by jwhitwell , Fri, May 25 2018 9:42 PM
5 1,388
Write a New Post
Page 10 of 25 (482 items) « First ... < Previous 8 9 10 11 12 Next > ... Last »
More Options

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller