Latest post Mon, Jul 17 2017 8:32 PM by Damien. 10 replies.
Page 1 of 1 (11 items)
Sort Posts: Previous Next
  • Mon, Jan 5 2015 5:12 PM

    • arie21
    • Not Ranked
    • Joined on Mon, Jan 5 2015
    • Posts 4
    • Points 60

    Assertion failed:m_PrimaryBufferPtr

    I reently just downloaded Avid to my mac which is running on Yosemite software. I had a trial version of avid on my computer last year and once the trial was done I unistalled avid and bought the software a few weeks ago. When I try to start up avid I get a message that tells me I do not have the necessary 8gb of RAM to run avid and I click on the proceed button. After I proceed I then get two speperate error messages that say the same thing. The first message comes from avid and says "Exception:FATAL_ERROR, msg:Assertion failed:m_pPrimaryBufferPtr,file:/Snapshots/relengmtnlion2_1418961066/coresw/core/src/player/ALocateBufferMgr.c, line:465" It only gives me the option to click ok and when i do aother messsage comes up with the same message but it then gives me the options "create report, exit application, continue and debugger" each one just leads the application to exit itself. 

    I'm not sure what kind of problem this is or how to fix it. Please help.

  • Mon, Jan 5 2015 5:56 PM In reply to

    Re: Assertion failed:m_PrimaryBufferPtr

    You seem to have the same problem as Robert in this thread Could you post your Mac model and specifications so we can see if there are hardware similarities

    Thanks

  • Mon, Jan 5 2015 6:04 PM In reply to

    • arie21
    • Not Ranked
    • Joined on Mon, Jan 5 2015
    • Posts 4
    • Points 60

    Re: Assertion failed:m_PrimaryBufferPtr

    MacBook Pro (13-inch, Mid 2010)

    2.4 GHz Intel Core 2 Duo (Processor) 

    4 GB 1067 MHz DDR3 (Memory)

    NVIDIA GeForce 320M 256 MB (Graphics)

    It's currently running on OS X Yosemite 10.10.1

  • Mon, Jan 5 2015 6:07 PM In reply to

    Re: Assertion failed:m_PrimaryBufferPtr

    Thanks I have asked Robert for details of his Laptop.

    FWIW I do not believe 8.3 is happy with less than 8GB's of RAM

  • Mon, Jan 5 2015 6:12 PM In reply to

    • arie21
    • Not Ranked
    • Joined on Mon, Jan 5 2015
    • Posts 4
    • Points 60

    Re: Assertion failed:m_PrimaryBufferPtr

    I was planning on upgrading my RAM that way I won't have to worry about crashes and just in case that was the casue for the error

  • Mon, Jan 5 2015 8:35 PM In reply to

    Re: Assertion failed:m_PrimaryBufferPtr

    Here's mine

     

    Early 2011 15" MBP  2.2 i7 quad core  AMD Radeon HD 6750M 1GB with automatic graqphics switiching   8 GB 1333MHz DDR3 SDRAM

     

     

    Thanks! 

     

     

    iMAC (late 2015) 4GHZ i7 - 32GB RAM - AMD R9 M395X 4GB 512 SSD BOOT BM Ultra Studio Express w/Driver 10.5.4. [view my complete system specs]
  • Mon, Jan 12 2015 10:01 PM In reply to

    • arie21
    • Not Ranked
    • Joined on Mon, Jan 5 2015
    • Posts 4
    • Points 60

    Re: Assertion failed:m_PrimaryBufferPtr

    Now when i try to open avid it just freezes and only responds to a force quit. Should i try unistalling and reinstalling the program?

  • Sat, Jan 17 2015 5:35 PM In reply to

    • amoscott07
    • Not Ranked
    • Joined on Sat, Jan 17 2015
    • Posts 1
    • Points 25

    Re: Assertion failed:m_PrimaryBufferPtr

    I was wondering if there is any way to go back to the previous version (version 8) instead of using version 8.30, which won't let you use less than 8gb.  My old version 8 worked fine on my Macbook pro (mid 2012) with only 4gb.

     

    Thoughts?  Many thanks!

  • Mon, Jan 19 2015 10:34 PM In reply to

    Re: Assertion failed:m_PrimaryBufferPtr

    amoscott07:
    I was wondering if there is any way to go back to the previous version (version 8) instead of using version 8.30

    Yes, you can always access older versions at the Avid Download Center.

     

    Symphony v8.8 | OS 10.11.6 • Nitris DX • 12-core MacPro (Mid 2012) • 36 GB RAM • Facilis Terrablock 24EX [view my complete system specs]

    -- Kevin

  • Sun, Feb 21 2016 6:40 AM In reply to

    • jlivesey
    • Not Ranked
    • Joined on Sun, Feb 21 2016
    • Posts 2
    • Points 30

    Re: Assertion failed:m_PrimaryBufferPtr

    I had a similar error and this helped me: http://avid.force.com/pkb/articles/en_US/troubleshooting/en373471

  • Mon, Jul 17 2017 8:32 PM In reply to

    • Damien
    • Not Ranked
    • Joined on Tue, Nov 22 2011
    • Geneva | Swtzerland
    • Posts 2
    • Points 5

    Re: Assertion failed:m_PrimaryBufferPtr

    Hi,

    I'm having a similar problem. I just bought a cross/grade licence, I'm unable to activate it. In the meantime I'm trying to instal a 30 day trial version. I've tried on two Macs: a 2014 MacPro and a 5K iMac, both are beefed with with ram. The MacPro in running Sierra and the iMac El Capitan. I've tried both 7.07 (because I have to open a project from that versoin) and 8.2, and on both Macs i'm getting the same message "Assertion failed: m_pPrimaryBufferPtr" upon start up and cannot launch MC.

    Any help is welcome.

    Cheers,
    Damien

     

    PS The thread linked above does not give me a solution as I cannot even open MC.

    2014 MacPro 3.5 Ghz 6-core, 32 GB ram, AMD FirePro D700 macOS Sierra 10.12.5 Adobe CC, DaVinci Resolve, Easy DCP, FCP X, Media Composer Black Magic... [view my complete system specs]
Page 1 of 1 (11 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller