Latest post Thu, Aug 9 2018 7:55 AM by gorky. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • Tue, Aug 7 2018 3:50 PM

    • Euchrow
    • Top 500 Contributor
    • Joined on Sat, Apr 15 2006
    • Brussels, Belgium
    • Posts 266
    • Points 3,480

    Avid 2018.7.1 not working on new MacBook Pro

    Hi there,

    My 2012 Macbook Pro died today, so I went and bought the new model because I'm in the middle of an edit. To my surprise Avid won't start at all on the new laptop. I immediately get a 'Exception: std::exception, what:Failed to change priority' message.

    This might have something to do with Avid not being supported on 10.13.6, which is the version the MacBook Pro is shipped with. However, I read on the forums that some people didn't have problems running Avid on 10.13.6. Or is it due to Avid not yet being compatible with the new hardware?

    Any ideas? I'm unable to downgrade OSX to 10.13.5 so at the moment my shiny and expensive new laptop is completely useless.

    thx

    Symphony 8.3 on Mac Pro Westmere 3.33Ghz 6 core, 48Gb Ram, Radeon 5770, Yosemite 10.10.1, Matrox MXO2 Mini 4.5 - MC 8.3 on MacBook Pro Retina 2.6 GHz,... [view my complete system specs]
  • Tue, Aug 7 2018 3:57 PM In reply to

    • Euchrow
    • Top 500 Contributor
    • Joined on Sat, Apr 15 2006
    • Brussels, Belgium
    • Posts 266
    • Points 3,480

    Re: Avid 2018.7.1 not working on new MacBook Pro

    Just read Marianna's post confirming the issue. Hopefully this gets sorted out soon.

    Symphony 8.3 on Mac Pro Westmere 3.33Ghz 6 core, 48Gb Ram, Radeon 5770, Yosemite 10.10.1, Matrox MXO2 Mini 4.5 - MC 8.3 on MacBook Pro Retina 2.6 GHz,... [view my complete system specs]
  • Tue, Aug 7 2018 5:45 PM In reply to

    • TrevorA
    • Top 100 Contributor
    • Joined on Thu, Oct 13 2005
    • London
    • Posts 1,045
    • Points 11,900

    Re: Avid 2018.7.1 not working on new MacBook Pro

    Fix imminent, hopefully.

  • Tue, Aug 7 2018 9:34 PM In reply to

    • AV
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Posts 3
    • Points 45

    Re: Avid 2018.7.1 not working on new MacBook Pro

    i'm running Avid Media Composer(R) 18.5.0 on mac os 10.13.6 and it's fine

    http://esd.avid.com/ProductDownload.aspx?id=1917

  • Wed, Aug 8 2018 5:48 AM In reply to

    • TrevorA
    • Top 100 Contributor
    • Joined on Thu, Oct 13 2005
    • London
    • Posts 1,045
    • Points 11,900

    Re: Avid 2018.7.1 not working on new MacBook Pro

    It’s the hardware, apparently, not the OS

  • Wed, Aug 8 2018 7:44 AM In reply to

    • gorky
    • Not Ranked
    • Joined on Wed, Nov 16 2005
    • Posts 125
    • Points 1,510

    Re: Avid 2018.7.1 not working on new MacBook Pro

    Try 2018.2 version.

  • Wed, Aug 8 2018 7:42 PM In reply to

    • Euchrow
    • Top 500 Contributor
    • Joined on Sat, Apr 15 2006
    • Brussels, Belgium
    • Posts 266
    • Points 3,480

    Re: Avid 2018.7.1 not working on new MacBook Pro

    gorky:

    Try 2018.2 version.

    Thx that works, great !

    Symphony 8.3 on Mac Pro Westmere 3.33Ghz 6 core, 48Gb Ram, Radeon 5770, Yosemite 10.10.1, Matrox MXO2 Mini 4.5 - MC 8.3 on MacBook Pro Retina 2.6 GHz,... [view my complete system specs]
  • Thu, Aug 9 2018 7:55 AM In reply to

    • gorky
    • Not Ranked
    • Joined on Wed, Nov 16 2005
    • Posts 125
    • Points 1,510

    Re: Avid 2018.7.1 not working on new MacBook Pro

    I think Avid programmers has added some sort of hardware filter from 2018.3 version. From 2018.3  MC filter out on start non sertificate processors. I have Hackintosh with 6 cores Xeon X5690 and Avid can't start with it with the same mistake. But if I change processor to more old and more weak i7-920 than Avid strt without mistake. Very strange. So I stucked on 2018.2 version.

Page 1 of 1 (8 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller