Latest post Thu, Dec 6 2018 4:02 PM by Isaac T.. 32 replies.
Page 1 of 3 (33 items) 1 2 3 Next >
Sort Posts: Previous Next
  • Mon, Nov 19 2018 7:58 AM

    • TrevorA
    • Top 100 Contributor
    • Joined on Thu, Oct 13 2005
    • London
    • Posts 1,069
    • Points 12,185

    Idea [I] Pg 2 - offical answer: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    https://support.apple.com/en-ca/HT209000

    In Final Cut Pro, you might see an alert that legacy media files won't be compatible with future macOS releases.

    Legacy media files are compatible with macOS Mojave, but they won't be with future macOS releases. Legacy media can include footage recorded with cameras like Sony HDCAM-SR cameras, footage from GoPro cameras recorded in the CineForm format, video files in the Avid DNxHD/DNxHR format created with software, footage shot with many other older cameras, or files modified with older software.”

    Does this mean we need to avoid Mac as a platform for DNx based Avid editing in future?  Or will this only affect FCPX/QTX?

  • Mon, Nov 19 2018 2:23 PM In reply to

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Sorry for my negativity but...

    Please Apple... please do this, after the welcomed end of quicktime development, also stop supporting DNxHR and stop producing Mac pro's and isolate yourself in your own i-hyperbole. And if Avid drops Apple as well, which I do not expect to happen, I will be happy!!!

    From the old Apple Quadro 950 to HP Z8xx. My current own system: 1x Z420 E5 1650 16GB memory, 128GB SSD, 1x XW8600, 2x 3.0Ghz Quadcore, 12GB memory... [view my complete system specs]

    Jeroen van Eekeres 

    Technical director, Broadcast support engineer, Avid ACSR.

     

    Always have a backup of your projects....Always!!!! Yes Always!!!!

    A.V.I.D....... Another Version In Development

    www.mediaoffline.com

     

     

     

  • Mon, Nov 19 2018 3:14 PM In reply to

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    That article seems to be focused on what Final Cut X supports, so I'm not sure it has any impact on Avid.

    Avid has been working to reduce its dependcy on QuickTime for a while now. I am sure that will continue and (hopefully) will be completed by the time Apple completely pulls the plug via the OS.

    Symphony v8.8 | OS 10.11.6 • Nitris DX • 12-core MacPro (Mid 2012) • 36 GB RAM • Facilis Terrablock 24EX [view my complete system specs]

    -- Kevin

  • Mon, Nov 19 2018 4:51 PM In reply to

    • jdrouette
    • Top 500 Contributor
    • Joined on Thu, Oct 13 2005
    • Vancouver, Canada
    • Posts 363
    • Points 4,760

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    I encountered the legacy media warning message in the latest version of Apple Compressor when I imported some DNxHD MXF files to transcode and was wondering what was going on.

    I'd really like come clarification from Avid and/or Apple about what's around the corner with format compatiblilty because Compressor is currently an integral part of my workflow.

    Avid Media Composer 2018.11 Symphony option, Avid Artist DNxID on macOS 10.14.1, iMac Pro (2017) 10-Core, 3.0GHz Intel Xeon W, Turbo Boost up to 4.5GHz... [view my complete system specs]
  • Tue, Nov 20 2018 7:27 PM In reply to

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    This article indicates that it is indeed the macOS dropping what to Apple is legacy support:

    https://nofilmschool.com/2018/11/why-apple-dropping-cineform-and-dnx-final-cut?fbclid=IwAR3ozuhKPetwod6ZqR8PVl5CMsnEO2xlq8wcm-6EhErz6lXKKliM6WfEFrM

    I really don't think this is anything new, just worded more explicitly. Quicktime is going away.

    What's called Quicktime Player 10 has always wanted to convert, not play, about anything but ProRes and some mpegs. With Quicktime and QT Player 7 gone, there won't be anything in the OS to play anything else.

    Avid and Adobe are both working to reduce dependency on QT so I'm confident DNxHD will live on. It's the older stuff that concerns me. There is no predicting what old footage a client is going to need restored from an archive some day.

    I will probably keep a couple of older Macs on the shelf with 10.13.6 installed for emergency restores and transcodes in the future. And Resolve supports many formats as well.

    Based on Apple's treatment of Shake, Final Cut Studio and Aperture, I would not count on Compressor and part of my workflow.

    Robert

     

     

     

     

  • Tue, Nov 20 2018 7:37 PM In reply to

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    I think this is referring to Quicktime legacy components - aka 32 bit based codecs.

     

     

    Edit: AVFoundation (aka QT X) does not support 3rd party codecs like Avid DNxHR or third party written camera codecs.

    MC 8.6.1, Windows 10, ASROCK X99M, Intel 5930K, Zotac GTX970, 32GB RAM, Transcend 512GB M.2 SSD & Dell U2713H. MBP 2012 Thunderbolt, OSX 10.10.5, MC... [view my complete system specs]
  • Tue, Nov 20 2018 7:49 PM In reply to

    • Marianna
    • Top 25 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 9,943
    • Points 214,780
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Hey all

    Jeremy our Mac god has reached out to apple on this and Apple is closed for the holiday so we wont know anything until next week....

    Remind me to bug engineering on this please...

    Marianna

    Director of Online Communities and Forums/Customer Advocate [view my complete system specs]

    marianna.montague@avid.com

    mobile 813-493-6800

    Twitter:  avidmarianna

    Facebook: Marianna Montague

    www.avidcustomerassociation.com   |  Connect 2019 | April 6-7 | Aria, Las Vegas, NV

    WWLD

  • Wed, Nov 21 2018 2:34 PM In reply to

    • Isaac T.
    • Top 150 Contributor
    • Joined on Mon, Jan 9 2006
    • New York
    • Posts 711
    • Points 8,445

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    @All: this article from Jon Chappell at Digital Rebellion is worth reading:

    Thoughts on 32-bit codecs being phased out in macOS - https://www.digitalrebellion.com/blog/posts/thoughts_on_32_bit_codecs_being_phased_out_in_macos

    Please read the whole article, then read it again. It's well-written and objective.

    That No Film School piece is highly sensationalized clickbait. They bury this, 'Of course, this is coming in a future version of macOS. Why Apple is doing this and when is not clear.' Exactly. So wait on Apple. They'll clarify. And they've heard enough from users to know this is a concern.

    If you wanna be heard by Apple, tell 'em! They're listening:

    https://www.apple.com/feedback/macos.html

    isaact.co | Demo ReelTwitter | Instagram | Vimeo

     

    Postproduction and Workflow Consultant - https://www.ijterronez.com/

  • Wed, Nov 21 2018 2:44 PM In reply to

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Isaac T.:
    That No Film School piece is *highly* sensationalized clickbait. They bury this, 'Of course, this is coming in a future version of macOS.

     

    The crux of the issue for the digital video industry is this

     

    "Because AV Foundation does not support third-party codecs."

     

     

    MC 8.6.1, Windows 10, ASROCK X99M, Intel 5930K, Zotac GTX970, 32GB RAM, Transcend 512GB M.2 SSD & Dell U2713H. MBP 2012 Thunderbolt, OSX 10.10.5, MC... [view my complete system specs]
  • Wed, Nov 21 2018 2:44 PM In reply to

    • luca.mg
    • Top 25 Contributor
    • Joined on Thu, Oct 13 2005
    • Roma - Italy
    • Posts 5,442
    • Points 63,775

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    More on this https://www.redsharknews.com/post/item/5971-apple-shock-move-drops-essential-codecs-maybe-to-prepare-for-move-away-from-intel

     

    Isaac T.:

    If you wanna by heard by Apple, tell them! They're listening:

    https://www.apple.com/feedback/macos.html

    not quite sure they do listen though...

    Symphony 2018.9, BM Intensity Pro 4k, Windows 10, i7-5930K, 32 GB ram, Quadro K620 [view my complete system specs]

    peace luca

  • Wed, Nov 21 2018 3:06 PM In reply to

    • Isaac T.
    • Top 150 Contributor
    • Joined on Mon, Jan 9 2006
    • New York
    • Posts 711
    • Points 8,445

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Dom Q. Silverio:
    "Because AV Foundation does not support third-party codecs."

    Yes.

    And if you Google / DuckDuckGo "quicktime av foundation", you'll find articles that date back years on AV Foundation.

    For example:

    https://devstreaming-cdn.apple.com/videos/wwdc/2013/606xdx2xbp31zp28fdov8p0b6d/606/606.pdf

    This is a deck from WWDC: Moving to AV Kit and AV Foundation. The year? 2013.

    isaact.co | Demo ReelTwitter | Instagram | Vimeo

     

    Postproduction and Workflow Consultant - https://www.ijterronez.com/

  • Wed, Nov 21 2018 3:15 PM In reply to

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Isaac T.:
    This is a deck from WWDC: Moving to AV Kit and AV Foundation. The year? 2013.

     

    ??

     

    Isn't the problem with AVFoundation with developers is that it does not support all the current functionalities of QT32? and the Apple VideoToolbox for AVF is not public yet? So not sure how "2013" here is of any relevance.

     

    MC 8.6.1, Windows 10, ASROCK X99M, Intel 5930K, Zotac GTX970, 32GB RAM, Transcend 512GB M.2 SSD & Dell U2713H. MBP 2012 Thunderbolt, OSX 10.10.5, MC... [view my complete system specs]
  • Wed, Nov 21 2018 3:20 PM In reply to

    • Isaac T.
    • Top 150 Contributor
    • Joined on Mon, Jan 9 2006
    • New York
    • Posts 711
    • Points 8,445

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Dom Q. Silverio:
    So not sure how "2013" here is of any relevance.

    The relevance is the writing's been on the wall for awhile, and this is just one layer of the puzzle.

    isaact.co | Demo ReelTwitter | Instagram | Vimeo

     

    Postproduction and Workflow Consultant - https://www.ijterronez.com/

  • Wed, Nov 21 2018 3:28 PM In reply to

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Isaac T.:
    The relevance is the writing's been on the wall for awhile, and this is just one layer of the puzzle.

    I'm missing something in this discussion because even if its "written on the wall", how does that address the issue that currently there is no solution still. There was no solution before (2013) and there is no solution now (2018). A puzzle assumes a solution is possible. There is, once Apple provides it.

    Avid writing a 64 bit AVF based codec in 2013 or 2018 does not solve the problem.

    Or are you suggesting that the developers (Adobe, Avid, Blackmagic, and the small developers) should have abandoned QT as a platform in 2014? Avid and Adobe are writting codes that removes dependencies from QT32 but that does not address other codecs from other companies AFAIK.

     

    MC 8.6.1, Windows 10, ASROCK X99M, Intel 5930K, Zotac GTX970, 32GB RAM, Transcend 512GB M.2 SSD & Dell U2713H. MBP 2012 Thunderbolt, OSX 10.10.5, MC... [view my complete system specs]
  • Wed, Nov 21 2018 3:41 PM In reply to

    • Marianna
    • Top 25 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 9,943
    • Points 214,780
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Avid DNxHD/DNxHR not compatible with macOS beyond Mojave?

    Dom Q. Silverio:

    Isaac T.:
    The relevance is the writing's been on the wall for awhile, and this is just one layer of the puzzle.

    I'm missing something in this discussion because even if its "written on the wall", how does that address the issue that currently there is no solution still. There was no solution before (2013) and there is no solution now (2018). A puzzle assumes a solution is possible. There is, once Apple provides it.

    Avid writing a 64 bit AVF based codec in 2013 or 2018 does not solve the problem.

    Or are you suggesting that the developers (Adobe, Avid, Blackmagic, and the small developers) should have abandoned QT as a platform in 2014? Avid and Adobe are writting codes that removes dependencies from QT32 but that does not address other codecs from other companies AFAIK.

    Spot on Dom.  I say lets wait and see what Jeremy at Avid hears from Apple once they are back from Holiday next week.

    Marianna

    Director of Online Communities and Forums/Customer Advocate [view my complete system specs]

    marianna.montague@avid.com

    mobile 813-493-6800

    Twitter:  avidmarianna

    Facebook: Marianna Montague

    www.avidcustomerassociation.com   |  Connect 2019 | April 6-7 | Aria, Las Vegas, NV

    WWLD

Page 1 of 3 (33 items) 1 2 3 Next >

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller